Minimal Hardware Requirement

  • 1GHz or higher 32-bit or 64-bit processor.
  • 2 GB of RAM.
  • 500 MB of hard disk space for installation.

 

Minimal Software Requirement

  • Windows XP service pack 3 or later.
  • .NET Framework 4.0. / .Net Framework 4.5 *
  • Microsoft Internet Explorer 8.0.
  • MYSQL 5.6*
  • Mozilla Firefox (For OpKey Recorder).
  • Adobe Flash Player 11(IE) or high (For Screen Cast)
  • Microsoft Office Excel 2007 – 2013-For Excel Data Connectivity.
  • PDF reader required for OpKey Result Reports(.pdf).
  • JAVA 8 - Required for installing DB Maintainer and Bamboo Integration
  • Oracle Data Access Components (ODAC) for Oracle Data base connectivity. (Click here for details)

Additional Software Requirement

  • Selenium Webdriver - IE Driver and Chrome Driver Servers for executing flow on Internet Explorer and Google Chrome.
  • Sikuli - JRE 1.8 and Sikuli IDE.
  • JIRA - Supports all JIRA versions from 5.0 to 7.0.
  • JENKINS - Supports JENKINS version 1.5 till 2.14 (Admin rights would be required).
  • Bamboo - Supports Bamboo version 5.8 & above (Admin rights would be required).
  • Appium - JDK 8 or above, Android SDK and Appium

 

* MySQL is required in higher editions of OpKey

* .Net 4.5 is required by Appium and Bamboo plug-in

For detailed information, please refer : https://opkey.crestechglobal.com/user-guide/pages.php?subid=64&accordid=2